.\" $OpenBSD: softraid.4,v 1.18 2008/06/14 00:16:38 hshoexer Exp $ .\" .\" Copyright (c) 2007 Todd T. Fries .\" Copyright (c) 2007 Marco Peereboom .\" .\" Permission to use, copy, modify, and distribute this software for any .\" purpose with or without fee is hereby granted, provided that the above .\" copyright notice and this permission notice appear in all copies. .\" .\" THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES .\" WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF .\" MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR .\" ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES .\" WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN .\" ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF .\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. .\" .Dd $Mdocdate: June 14 2008 $ .Dt SOFTRAID 4 .Os .Sh NAME .Nm softraid .Nd Software RAID .Sh SYNOPSIS .Cd "softraid0 at root" .Cd "scsibus* at softraid?" .Sh DESCRIPTION The .Nm device emulates a Host Bus Adapter (HBA) that provides RAID and other I/O related services. The .Nm device provides a scaffold to implement more complex I/O transformation disciplines. For example, one can tie chunks together into a mirroring discipline. There really is no limit on what type of discipline one can write as long as it fits the SCSI model. .Pp .Nm supports a number of .Em disciplines . A discipline is a collection of functions that provides specific I/O functionality. This includes I/O path, bring-up, failure recovery, statistical information gathering etc.\& Essentially a discipline is a lower level driver that provides the I/O transformation for the softraid device. .Pp Currently .Nm supports the following disciplines: .Bl -ohang -offset indent .It RAID 0 A .Em striping discipline. It segments data over a number of disks to increase performance. RAID 0 does not provide for data loss (redundancy). .It RAID 1 A .Em mirroring discipline. It copies data across more than one disk to provide for data loss. Read performance is increased, though at the cost of write speed. Unlike traditional RAID 1, .Nm supports the use of more than two disks in a RAID 1 setup. .It CRYPTO An .Em encrypting discipline. It encrypts data on a single disk to provide for data confidentiality. CRYPTO does not provide redundancy. .El .Pp A .Em volume is a virtual disk device that is made up of a collection of chunks. .Pp A .Em chunk is a partition or storage area of the type RAID. .Sh EXAMPLES An example to create a 3 chunk RAID 1 from scratch is as follows: .Pp Initialize the partition tables of all disks: .Bd -literal -offset indent # fdisk -iy wd1 # fdisk -iy wd2 # fdisk -iy wd3 .Ed .Pp Now create RAID partitions on all disks: .Bd -literal -offset indent # printf "a\en\en\en\enRAID\enw\enq\en\en" | disklabel -E wd1 # printf "a\en\en\en\enRAID\enw\enq\en\en" | disklabel -E wd2 # printf "a\en\en\en\enRAID\enw\enq\en\en" | disklabel -E wd3 .Ed .Pp Assemble the RAID volume: .Bd -literal -offset indent # bioctl -c 1 -l /dev/wd1a,/dev/wd2a,/dev/wd3a softraid0 .Ed .Pp The console will show what device was added to the system: .Bd -literal -offset indent scsibus0 at softraid0: 1 targets sd0 at scsibus0 targ 0 lun 0: SCSI2 sd0: 1MB, 0 cyl, 255 head, 63 sec, 512 bytes/sec, 3714 sec total .Ed .Pp It is good practice to wipe the front of the disk before using it: .Bd -literal -offset indent # dd if=/dev/zero of=/dev/rsd0c bs=1m count=1 .Ed .Pp Initialize the partition table and create a filesystem on the new RAID volume: .Bd -literal -offset indent # fdisk -iy sd0 # printf "a\en\en\en\en4.2BSD\enw\enq\en\en" | disklabel -E sd0 # newfs /dev/rsd0a .Ed .Pp The RAID volume is now ready to be used as a normal disk device. .Pp See .Xr bioctl 8 for more information on configuration of RAID sets. .Pp All component partitions must be of type .Dv RAID . Some platforms, such as SUN, are not capable of using the .Dv RAID partition type. The .Dv 4.2BSD partition type should be used on such platforms. .Sh SEE ALSO .Xr sd 4 , .Xr wd 4 , .Xr bioctl 8 , .Xr config 8 , .Xr fsck 8 , .Xr MAKEDEV 8 , .Xr mount 8 , .Xr newfs 8 .Sh HISTORY The .Nm driver first appeared in .Ox 4.2 . .Sh AUTHORS .An Marco Peereboom . .Sh CAVEATS The driver relies on underlying hardware to properly fail chunks. Currently RAID 1 support does not have the ability to recover a failed chunk. .Pp The RAID 1 discipline does not initialize the mirror upon creation. This is by design because all sectors that are read are written first. There is no point in wasting a lot of time syncing random data. .Pp Currently there is no automated mechanism to recover from failed disks. .Pp There is no boot support at this time for any disciplines. .Pp Certain RAID levels can protect against some data loss due to component failure. RAID is .Em not a substitute for good backup practices.